Notes on degraded disks in TrueNas
Diagnostics results
July 22, 2025
Walnut does not appear in the list of pools.
root@storage[~]# zpool status -v
pool: freenas-boot
state: ONLINE
status: One or more features are enabled on the pool despite not being
requested by the 'compatibility' property.
action: Consider setting 'compatibility' to an appropriate value, or
adding needed features to the relevant file in
/etc/zfs/compatibility.d or /usr/share/zfs/compatibility.d.
scan: scrub repaired 0B in 00:02:54 with 0 errors on Sat Jul 19 03:47:56 2025
config:
NAME STATE READ WRITE CKSUM
freenas-boot ONLINE 0 0 0
ata-WDC_WD5000AAVS-00ZTB0_WD-WCASU1729787-part2 ONLINE 0 0 0
errors: No known data errors
Walnut isn’t there.
root@storage[~]# zpool status -v walnut
cannot open 'walnut': no such pool
But Walnut is available to import.
root@storage[~]# zpool import
pool: walnut
id: 1961939703700026420
state: DEGRADED
status: One or more devices are faulted.
action: The pool can be imported despite missing or damaged devices. The
fault tolerance of the pool may be compromised if imported.
config:
walnut DEGRADED
mirror-0 DEGRADED
sdc2 FAULTED too many errors
sdb2 ONLINE
root@storage[~]# smartctl -a /dev/sdb2
smartctl 7.4 2023-08-01 r5530 [x86_64-linux-6.6.44-production+truenas] (local build)
Copyright (C) 2002-23, Bruce Allen, Christian Franke, www.smartmontools.org
=== START OF INFORMATION SECTION ===
Model Family: Western Digital Red (SMR)
Device Model: WDC WD60EFAX-68SHWN0
Serial Number: WD-WX42D100J943
LU WWN Device Id: 5 0014ee 267a871b1
Firmware Version: 82.00A82
User Capacity: 6,001,175,126,016 bytes [6.00 TB]
Sector Sizes: 512 bytes logical, 4096 bytes physical
Rotation Rate: 5400 rpm
Form Factor: 3.5 inches
TRIM Command: Available
Device is: In smartctl database 7.3/5787
ATA Version is: ACS-3 T13/2161-D revision 5
SATA Version is: SATA 3.1, 6.0 Gb/s (current: 3.0 Gb/s)
Local Time is: Tue Jul 22 21:42:09 2025 EDT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled
=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED
General SMART Values:
Offline data collection status: (0x00) Offline data collection activity
was never started.
Auto Offline Data Collection: Disabled.
Self-test execution status: ( 0) The previous self-test routine completed
without error or no self-test has ever
been run.
Total time to complete Offline
data collection: (49440) seconds.
Offline data collection
capabilities: (0x7b) SMART execute Offline immediate.
Auto Offline data collection on/off support.
Suspend Offline collection upon new
command.
Offline surface scan supported.
Self-test supported.
Conveyance Self-test supported.
Selective Self-test supported.
SMART capabilities: (0x0003) Saves SMART data before entering
power-saving mode.
Supports SMART auto save timer.
Error logging capability: (0x01) Error logging supported.
General Purpose Logging supported.
Short self-test routine
recommended polling time: ( 2) minutes.
Extended self-test routine
recommended polling time: ( 755) minutes.
Conveyance self-test routine
recommended polling time: ( 2) minutes.
SCT capabilities: (0x303d) SCT Status supported.
SCT Error Recovery Control supported.
SCT Feature Control supported.
SCT Data Table supported.
SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
1 Raw_Read_Error_Rate 0x002f 185 179 051 Pre-fail Always - 811
3 Spin_Up_Time 0x0027 253 224 021 Pre-fail Always - 1241
4 Start_Stop_Count 0x0032 100 100 000 Old_age Always - 42
5 Reallocated_Sector_Ct 0x0033 161 161 140 Pre-fail Always - 1558
7 Seek_Error_Rate 0x002e 200 200 000 Old_age Always - 113
9 Power_On_Hours 0x0032 041 041 000 Old_age Always - 43719
10 Spin_Retry_Count 0x0032 100 100 000 Old_age Always - 0
11 Calibration_Retry_Count 0x0032 100 100 000 Old_age Always - 0
12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always - 42
192 Power-Off_Retract_Count 0x0032 200 200 000 Old_age Always - 34
193 Load_Cycle_Count 0x0032 200 200 000 Old_age Always - 20
194 Temperature_Celsius 0x0022 126 115 000 Old_age Always - 24
196 Reallocated_Event_Count 0x0032 001 001 000 Old_age Always - 1558
197 Current_Pending_Sector 0x0032 200 200 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0030 100 253 000 Old_age Offline - 0
199 UDMA_CRC_Error_Count 0x0032 200 200 000 Old_age Always - 0
200 Multi_Zone_Error_Rate 0x0008 100 253 000 Old_age Offline - 0
SMART Error Log Version: 1
No Errors Logged
SMART Self-test log structure revision number 1
Num Test_Description Status Remaining LifeTime(hours) LBA_of_first_error
# 1 Short offline Completed: read failure 90% 43713 118946664
# 2 Extended offline Completed: read failure 90% 39554 2352114784
SMART Selective self-test log data structure revision number 1
SPAN MIN_LBA MAX_LBA CURRENT_TEST_STATUS
1 0 0 Not_testing
2 0 0 Not_testing
3 0 0 Not_testing
4 0 0 Not_testing
5 0 0 Not_testing
Selective self-test flags (0x0):
After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.
The above only provides legacy SMART information - try 'smartctl -x' for more
root@storage[~]# smartctl -a /dev/sdc2
smartctl 7.4 2023-08-01 r5530 [x86_64-linux-6.6.44-production+truenas] (local build)
Copyright (C) 2002-23, Bruce Allen, Christian Franke, www.smartmontools.org
=== START OF INFORMATION SECTION ===
Model Family: Western Digital Red (SMR)
Device Model: WDC WD60EFAX-68SHWN0
Serial Number: WD-WX42D10HZV4V
LU WWN Device Id: 5 0014ee 267a86e9c
Firmware Version: 82.00A82
User Capacity: 6,001,175,126,016 bytes [6.00 TB]
Sector Sizes: 512 bytes logical, 4096 bytes physical
Rotation Rate: 5400 rpm
Form Factor: 3.5 inches
TRIM Command: Available
Device is: In smartctl database 7.3/5787
ATA Version is: ACS-3 T13/2161-D revision 5
SATA Version is: SATA 3.1, 6.0 Gb/s (current: 3.0 Gb/s)
Local Time is: Tue Jul 22 21:52:37 2025 EDT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled
=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED
General SMART Values:
Offline data collection status: (0x00) Offline data collection activity
was never started.
Auto Offline Data Collection: Disabled.
Self-test execution status: ( 0) The previous self-test routine completed
without error or no self-test has ever
been run.
Total time to complete Offline
data collection: (49680) seconds.
Offline data collection
capabilities: (0x7b) SMART execute Offline immediate.
Auto Offline data collection on/off support.
Suspend Offline collection upon new
command.
Offline surface scan supported.
Self-test supported.
Conveyance Self-test supported.
Selective Self-test supported.
SMART capabilities: (0x0003) Saves SMART data before entering
power-saving mode.
Supports SMART auto save timer.
Error logging capability: (0x01) Error logging supported.
General Purpose Logging supported.
Short self-test routine
recommended polling time: ( 2) minutes.
Extended self-test routine
recommended polling time: ( 738) minutes.
Conveyance self-test routine
recommended polling time: ( 2) minutes.
SCT capabilities: (0x303d) SCT Status supported.
SCT Error Recovery Control supported.
SCT Feature Control supported.
SCT Data Table supported.
SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
1 Raw_Read_Error_Rate 0x002f 103 103 051 Pre-fail Always - 4588
3 Spin_Up_Time 0x0027 225 224 021 Pre-fail Always - 3716
4 Start_Stop_Count 0x0032 100 100 000 Old_age Always - 42
5 Reallocated_Sector_Ct 0x0033 200 200 140 Pre-fail Always - 0
7 Seek_Error_Rate 0x002e 200 200 000 Old_age Always - 0
9 Power_On_Hours 0x0032 041 041 000 Old_age Always - 43725
10 Spin_Retry_Count 0x0032 100 253 000 Old_age Always - 0
11 Calibration_Retry_Count 0x0032 100 253 000 Old_age Always - 0
12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always - 42
192 Power-Off_Retract_Count 0x0032 200 200 000 Old_age Always - 34
193 Load_Cycle_Count 0x0032 200 200 000 Old_age Always - 33
194 Temperature_Celsius 0x0022 126 114 000 Old_age Always - 24
196 Reallocated_Event_Count 0x0032 200 200 000 Old_age Always - 0
197 Current_Pending_Sector 0x0032 200 200 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0030 100 253 000 Old_age Offline - 0
199 UDMA_CRC_Error_Count 0x0032 200 200 000 Old_age Always - 0
200 Multi_Zone_Error_Rate 0x0008 100 253 000 Old_age Offline - 0
SMART Error Log Version: 1
ATA Error Count: 6084 (device log contains only the most recent five errors)
CR = Command Register [HEX]
FR = Features Register [HEX]
SC = Sector Count Register [HEX]
SN = Sector Number Register [HEX]
CL = Cylinder Low Register [HEX]
CH = Cylinder High Register [HEX]
DH = Device/Head Register [HEX]
DC = Device Command Register [HEX]
ER = Error register [HEX]
ST = Status register [HEX]
Powered_Up_Time is measured from power on, and printed as
DDd+hh:mm:SS.sss where DD=days, hh=hours, mm=minutes,
SS=sec, and sss=millisec. It "wraps" after 49.710 days.
Error 6084 occurred at disk power-on lifetime: 43725 hours (1821 days + 21 hours)
When the command that caused the error occurred, the device was active or idle.
After command completion occurred, registers were:
ER ST SC SN CL CH DH
-- -- -- -- -- -- --
04 61 02 00 00 00 a0 Device Fault; Error: ABRT
Commands leading to the command that caused the error were:
CR FR SC SN CL CH DH DC Powered_Up_Time Command/Feature_Name
-- -- -- -- -- -- -- -- ---------------- --------------------
ef 10 02 00 00 00 a0 08 05:30:18.728 SET FEATURES [Enable SATA feature]
ec 00 00 00 00 00 a0 08 05:30:18.677 IDENTIFY DEVICE
ef 03 46 00 00 00 a0 08 05:30:18.677 SET FEATURES [Set transfer mode]
ef 10 02 00 00 00 a0 08 05:30:18.676 SET FEATURES [Enable SATA feature]
ec 00 00 00 00 00 a0 08 05:30:18.675 IDENTIFY DEVICE
Error 6083 occurred at disk power-on lifetime: 43725 hours (1821 days + 21 hours)
When the command that caused the error occurred, the device was active or idle.
After command completion occurred, registers were:
ER ST SC SN CL CH DH
-- -- -- -- -- -- --
04 61 46 00 00 00 a0 Device Fault; Error: ABRT
Commands leading to the command that caused the error were:
CR FR SC SN CL CH DH DC Powered_Up_Time Command/Feature_Name
-- -- -- -- -- -- -- -- ---------------- --------------------
ef 03 46 00 00 00 a0 08 05:30:18.677 SET FEATURES [Set transfer mode]
ef 10 02 00 00 00 a0 08 05:30:18.676 SET FEATURES [Enable SATA feature]
ec 00 00 00 00 00 a0 08 05:30:18.675 IDENTIFY DEVICE
ef 10 02 00 00 00 a0 08 05:30:18.617 SET FEATURES [Enable SATA feature]
Error 6082 occurred at disk power-on lifetime: 43725 hours (1821 days + 21 hours)
When the command that caused the error occurred, the device was active or idle.
After command completion occurred, registers were:
ER ST SC SN CL CH DH
-- -- -- -- -- -- --
04 61 02 00 00 00 a0 Device Fault; Error: ABRT
Commands leading to the command that caused the error were:
CR FR SC SN CL CH DH DC Powered_Up_Time Command/Feature_Name
-- -- -- -- -- -- -- -- ---------------- --------------------
ef 10 02 00 00 00 a0 08 05:30:18.676 SET FEATURES [Enable SATA feature]
ec 00 00 00 00 00 a0 08 05:30:18.675 IDENTIFY DEVICE
ef 10 02 00 00 00 a0 08 05:30:18.617 SET FEATURES [Enable SATA feature]
ec 00 00 00 00 00 a0 08 05:30:18.563 IDENTIFY DEVICE
Error 6081 occurred at disk power-on lifetime: 43725 hours (1821 days + 21 hours)
When the command that caused the error occurred, the device was active or idle.
After command completion occurred, registers were:
ER ST SC SN CL CH DH
-- -- -- -- -- -- --
04 61 02 00 00 00 a0 Device Fault; Error: ABRT
Commands leading to the command that caused the error were:
CR FR SC SN CL CH DH DC Powered_Up_Time Command/Feature_Name
-- -- -- -- -- -- -- -- ---------------- --------------------
ef 10 02 00 00 00 a0 08 05:30:18.617 SET FEATURES [Enable SATA feature]
ec 00 00 00 00 00 a0 08 05:30:18.563 IDENTIFY DEVICE
ef 03 46 00 00 00 a0 08 05:30:18.563 SET FEATURES [Set transfer mode]
ef 10 02 00 00 00 a0 08 05:30:18.562 SET FEATURES [Enable SATA feature]
ec 00 00 00 00 00 a0 08 05:30:18.551 IDENTIFY DEVICE
Error 6080 occurred at disk power-on lifetime: 43725 hours (1821 days + 21 hours)
When the command that caused the error occurred, the device was active or idle.
After command completion occurred, registers were:
ER ST SC SN CL CH DH
-- -- -- -- -- -- --
04 61 46 00 00 00 a0 Device Fault; Error: ABRT
Commands leading to the command that caused the error were:
CR FR SC SN CL CH DH DC Powered_Up_Time Command/Feature_Name
-- -- -- -- -- -- -- -- ---------------- --------------------
ef 03 46 00 00 00 a0 08 05:30:18.563 SET FEATURES [Set transfer mode]
ef 10 02 00 00 00 a0 08 05:30:18.562 SET FEATURES [Enable SATA feature]
ec 00 00 00 00 00 a0 08 05:30:18.551 IDENTIFY DEVICE
ef 10 02 00 00 00 a0 08 05:30:18.506 SET FEATURES [Enable SATA feature]
SMART Self-test log structure revision number 1
No self-tests have been logged. [To run self-tests, use: smartctl -t]
SMART Selective self-test log data structure revision number 1
SPAN MIN_LBA MAX_LBA CURRENT_TEST_STATUS
1 0 0 Not_testing
2 0 0 Not_testing
3 0 0 Not_testing
4 0 0 Not_testing
5 0 0 Not_testing
Selective self-test flags (0x0):
After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.
The above only provides legacy SMART information - try 'smartctl -x' for more
sdb2 can still be read.
root@storage[~]# zdb -l /dev/sdb2
------------------------------------
LABEL 0
------------------------------------
version: 5000
name: 'walnut'
state: 0
txg: 29766536
pool_guid: 1961939703700026420
errata: 0
# hostid: 859060532
hostname: 'storage'
top_guid: 1808261124449960641
guid: 17335523875493946405
vdev_children: 1
vdev_tree:
type: 'mirror'
id: 0
guid: 1808261124449960641
metaslab_array: 39
metaslab_shift: 35
ashift: 12
asize: 5999022833664
is_log: 0
create_txg: 4
children[0]:
type: 'disk'
id: 0
guid: 14877326524672082977
path: '/dev/sdc2'
phys_path: 'id1,enc@n3061686369656d30/type@0/slot@1/elmdesc@Slot_00/p2'
DTL: 286
create_txg: 4
children[1]:
type: 'disk'
id: 1
guid: 17335523875493946405
path: '/dev/sdb2'
phys_path: 'id1,enc@n3061686369656d30/type@0/slot@2/elmdesc@Slot_01/p2'
DTL: 285
create_txg: 4
features_for_read:
com.delphix:hole_birth
com.delphix:embedded_data
labels = 0 1 2 3
sdc2 is well and truly dead.
root@storage[~]# zdb -l /dev/sdc2
failed to read label 0
failed to read label 1
failed to read label 2
failed to read label 3
root@storage[~]# zpool import walnut
cannot mount '/walnut': failed to create mountpoint: Read-only file system
Import was successful, but unable to mount some datasets
This imports walnut; visible again in the CLI.
zpool import -o altroot=/mnt walnut
Next steps
I tried to rsync the most important data off the drive (/mnt/walnut/cz) overnight,
but not much copied. TrueNAS scale also initiated a scrub, which maybe I should have stopped.
One way or another, sdb2 can no longer be read by zfs, and also appears to be dead.
Our current priority is recovery of photos added to dataset cz since the last backup,
2024-11-03. To do this, we will drop down out of zfs to try to recover bits.
- Using ddrescue, starting with a byte-by-byte copy once large new drives arrive.
- Potentially sending to a data recovery service.
At the same time, try to recover photos from camera SD card and from Zuz’s computer.
Preventing this from happening again
- We need an automated backup. We can use ZFS snapshot replication for this.
- Consider using sanoid
- A Raspberry Pi attached to a big external hard disk, in my UB office.
Update 2025-09-07
I spoke with Chris at https://www.pcsrecovery.com/; he said that for two drives in mirrored configuration he would cap the cost at $1450, and no charge (other than parts) if no data can be recovered.
Here are the drop off instructions:
It’s self drop-off Monday through Thursday between 9:30am and 4:30pm. Fridays 9:30-1pm.
Just go to 2437 Berg Road in West Seneca, walk into suite H, complete the service request that you’ll see on the table, then place the drives in any open lockbox in the room and lock it.
Make sure you go down the hall and walk into suite H on the left.
Please text this number and let us know you dropped it off once it’s in the safe. Thank you!
Chris recovered the data.
Recovery
root@storage[/]# mkdir /mnt/recovery
root@storage[/]# mount /dev/sdb /mnt/recovery
root@storage[/]# cd /mnt/recovery
root@storage[/mnt/recovery]# cd RECOVERED
root@storage[/mnt/recovery/RECOVERED]# ls
chris cp_time_machine cz public zuzia